Unloadable Saves after Day 30

Help for your technical issues with Slime Rancher

Unloadable Saves after Day 30

Postby squintlysays » Fri Jun 01, 2018 7:25 pm

So I have encountered a problem where, after a certain amount of playtime, quitting the game and then trying to load the save file results in a blank white screen (in windowed mode, or an 'invisible' screen showing through to the desktop in full screen). I can still hear the appropriate sounds, including the vacpack when I click, but the screen is entirely white (or invisible). No amount of waiting resolves this, and I have checked my computer resources and everything stays well under 50% capacity, so it isn't a memory leak.

The first time this happened, I thought it was because I had 'finished' the game, receiving the final cutscene/credits sequence for the first time. I started a new game, and began to explore some of the newer content instead of heading straight for the Glass Desert as I had the first time, but sure enough, after ~30 days, when I quit and tried to reboot, white screen.

I had been having (what I now know to be unrelated) driver issues, so I spent a few days fixing that, and then returned to Slime Rancher, hoping the problem would be solved. My old saves would not load, but a new game worked fine. Until I hit 30 days.

Finally, I decide I'm going to reinstall the game (somewhat of a trial because of my terrible internet). I boot it up, and my old saves don't load, but they're already corrupted so that should be fine in theory. I delete them (mistake, but I was optimistic) and start up a new file. 30 days. White screen.

Now, it doesn't happen at exactly thirty days -- total day count ranged from 31 to 45, depending on how many days had passed between hitting 30 and me shutting down the game for the day (I tend to play in long sessions). I'm assuming there's some kind of build-up going on here? Maybe a memory leak, though as I said, I have no more than 50% resources used even when booting up the game. It could be related to the Casey letters? But I stopped reading them, thinking if I ignored them I could avoid the issue (and also reading them for the 5th time did not appeal overly much). Honestly, I have no idea what's happening, but it's incredibly frustrating, knowing that in Adventure Mode, I have a limited timeframe, and with my current skills/abilities, cannot possibly complete all content in the game before the save corrupts.

I've tried to send a bug report via F2, but though I can tell *something* happens (the sound disappears) I still can't see anything to actually report the bug. So I'm coming here. Hopefully this can be fixed -- this is one of my favorite games, and this issue has basically ruined it.

(BTW -- I tried to attach my log file, but it says the extension txt is not allowed, which is kind of strange given that that's literally the default extension for the most important attachment type on this forum. But that's neither here nor there.)



Nvidia GTX 1050 graphics card
Intel i7-7700HQ CPU @ 2.80GHz
16 GB Ram
Windows 10 64-Bit, Home Addition, Version 1709, OS Build 16299.431
Posts: 1
Joined: Fri Jun 01, 2018 6:48 pm

Re: Unloadable Saves after Day 30

Postby JinxieUnlucky » Sat Jun 02, 2018 11:34 am

I've been having a similar issue. In my most recent files (one of them at day 109 and the other at day 35) every time I try to load them I get frozen on the loading screen. I can hear the slimes cooing and my vacpac going but I get stuck on the loading screen or an empty black screen. I recently started up a new save and just kept sleeping until morning until I hit 32 days, but this one seems to load just fine, so I don't really know what the issue is. At one point it made my whole computer crash. I'm kind of frustrated bc I don't want to have to keep creating new saves every time I hit 30 days either ):
User avatar
Posts: 1
Joined: Sat Oct 21, 2017 1:09 pm

Return to Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests