Puddle slimes disappearing from ponds bug

Help for your technical issues with Slime Rancher

Puddle slimes disappearing from ponds bug

Postby Heather » Sat Jan 16, 2016 5:34 pm

I've been trying to figure out why my puddle slimes keep disappearing from my ponds, and believe I have figured it out.
Posting here because it seems to be a bug that's easy to duplicate.

If you have a puddle slime in your pond, and shoot water at it - it leaves behind the same "slime splatter" as slimes on land leave when hit with something. Note the two blue patches in the pic below.
This seems to fool the game into thinking the slime is on land, not in the pond.. and start the same timer as if it was thrown on land. Seconds later, it disappears... even though it is in the water (pond).

I'll post specs if needed but this doesn't seem to be an issue on my end?

Image
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: Puddle slimes disappearing from ponds bug

Postby Heather » Sat Jan 16, 2016 9:43 pm

Shortly after, I added two new slimes and did not splash them with any water this time.
Returned much later, and they were still there... but hungry looking, even though they were in a full pond (see below).
So, I fed them... and they disappeared again after leaving behind plorts and some "slime splatter".

Image
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: Puddle slimes disappearing from ponds bug

Postby PawBean » Sun Jan 17, 2016 1:45 am

Good job! I hope this helps solve the problem c:
Another thing I found related to the pond slimes is that shooting water at pond plorts makes them vanish, so maybe there's a connection?
Edit: It's the same things for the slimes themselves. The first time they touch the floor of the pond when you shoot them in doesn't make them vanish but the moment shoot water at them they despawn after 30 seconds, so there should be some sort of connection.
Last edited by PawBean on Sun Jan 17, 2016 5:48 am, edited 1 time in total.
User avatar
PawBean
Chickadoo
 
Posts: 10
Joined: Thu Jan 14, 2016 8:47 am

Re: Puddle slimes disappearing from ponds bug

Postby Heather » Sun Jan 17, 2016 11:49 am

Thanks for the feedback gang... it's appreciated Image

One other pond-related item that may not be working as intended...
Even when the water inventory slot is full, you can continue to drain the pond of water.

Image

Image
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: Puddle slimes disappearing from ponds bug

Postby Heather » Sun Jan 17, 2016 1:53 pm

It should be noted the second post about the starving puddle slimes was from a pond I had in the overgrowth, furthest from the entrance.
I added four puddles and left them alone in the pond in my main ranch area, closest to the grotto entrance... and they did not starve. They seemed capable of feeding themselves. (see below).
However they did disappear when shot with water while in the pond there as well.
Hope this helps.

Image
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: Puddle slimes disappearing from ponds bug

Postby Mike » Sun Jan 17, 2016 3:32 pm

A fix for both the Puddle Plorts getting hit by water and the Puddle Slimes disappearing while in ponds should be included in the next release. I'll note it in the Known Issues thread.

(The speculation above that the two bugs might be related was, indeed, correct.)
User avatar
Mike
Developer
 
Posts: 28
Joined: Wed Feb 04, 2015 6:12 pm

Re: Puddle slimes disappearing from ponds bug

Postby NekoSlime » Sun Jan 17, 2016 4:26 pm

They can disappear even without shooting water at them, because the edges of the pond are considered "land" and therefore, because of the slime's strange fixation with sticking to the edges of the pond as hard as it can, will inevitably press against the raised edges and soon evaporate.

The pond needs to be restructured. Additionally, the puddle slime AI needs to not move around quite as much.
User avatar
NekoSlime
Rancher
 
Posts: 48
Joined: Sat Jan 16, 2016 6:29 am

Re: Puddle slimes disappearing from ponds bug

Postby clmurphy74 » Mon Jan 18, 2016 12:29 am

My puddle slime disappeared from the pond I had in the Grotto the other day (about the 15/16th of January). I wondered at the time if it was a bug or did my slime just die/disappear but I did shoot water into the pond (not directly at the puddle slime). I am attempting to corral other puddle slimes, to test ponds in the main area and the overrun area as well.

This was before I upgraded to 0.2.3b (it's the main reason I upgraded, in fact)
User avatar
clmurphy74
Rancher
 
Posts: 115
Joined: Sat Jan 16, 2016 8:40 pm

Re: Puddle slimes disappearing from ponds bug

Postby FoxLocks » Mon Jan 18, 2016 5:58 pm

I found my puddle slimes were actually vanishing, they were getting LAUNCHED out of my pond. I kept finding them in my other expansion zones and sometimes behind my little house.
Honey Boom are the best <3
User avatar
FoxLocks
Chickadoo
 
Posts: 11
Joined: Tue Jan 12, 2016 6:32 pm

Re: Puddle slimes disappearing from ponds bug

Postby Snow » Sun Jan 24, 2016 9:47 am

FoxLocks wrote:I found my puddle slimes were actually vanishing, they were getting LAUNCHED out of my pond. I kept finding them in my other expansion zones and sometimes behind my little house.


I'm getting this too. The puddle slimes seem to be *extremely* floaty when not in their pond, like they're always in water no matter what height they're at. I've been vac'ing up plorts from the pond and one will bounce off and I'll find it stuck halfway up a wall on the opposite side of my ranch.

To avoid this I've just been collecting them when I have at least 2 slots open so I just get them and their plorts and then I just shoot them back into the pond afterward.
User avatar
Snow
Plort
 
Posts: 6
Joined: Sun Jan 24, 2016 9:40 am
Location: New Hampshire

Re: Puddle slimes disappearing from ponds bug

Postby clmurphy74 » Mon Jan 25, 2016 3:07 pm

My Puddle slimes seem to be behaving now. I too have to have at least 2 slots open, just in case I bounce one out of the pond. Also, it seems that my pond is draining, but it looks full? I found my slimes under the water, but the graphic showed a full pond. I've been making a run to the nearest spring, gathering 50 spots of water, collecting any puddle plorts and slimes, shooting the water into the pond, then replacing the slimes. They seem to be very happy with their home.
User avatar
clmurphy74
Rancher
 
Posts: 115
Joined: Sat Jan 16, 2016 8:40 pm


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 0 guests