wont launch in Lubuntu

Help for your technical issues with Slime Rancher

wont launch in Lubuntu

Postby mybestskills » Tue Feb 09, 2016 10:38 am

Sent in a log file to the email address. I have a good enough computer that exceeds the system requirements. Did a sudo apt-update in terminal. Pulse audio is working. Other games are working. Even tried deleting the slimerancher.prf as I have seen in another thread but that was for windows. Figured I would try it on linux. Didn't work. Funny thing was when I first installed the game it actually ran all the way into the main screen. I went to the settings menu to crank up the graphics for the hell of it. Ever since I did that, it never ran again. I seen that the tested platform for this game was only in steamOS. Never used it before. But I downloaded it for the hell of it. I was thinking of trying it out on my other hard drive. But I rather not switch back and forth between hard drives/operating systems. If anyone has a trick or tip on the issue for my operating system or whatnot give me a shout. Is there a file where I can edit the graphics preferences? Seems like that is what did it in when it installed. But my system well exceeds the min. requirements. I am using amd drivers not the open source drivers. I figured that the sudo apt-get update would update most or all drivers/programs tied to a repository. Anyways thank you.
mybestskills
Plort
 
Posts: 5
Joined: Sun Feb 07, 2016 5:22 am
Location: Canaan Indiana

Re: wont launch in Lubuntu

Postby Heather » Tue Feb 09, 2016 10:44 am

Welcome, sorry you're having trouble.
I'm glad you've sent your log in.
Other than updating your audio and video drivers, take a look at this thread and see if that helps.
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: wont launch in Lubuntu

Postby mybestskills » Tue Feb 09, 2016 12:26 pm

well me and my wife tried this. Maybe its my lack of understanding or lack of description. Is it basically telling me to copy a file into the command launch area? Like it wont let me paste the file itself... so I opened the perf file and copied the entire script which wasn't much. Where I get lost is where do I paste the perf file at? How would it look towards the end of the process instead of guessing where the pieces fit in the puzzle. What do I do with the regular slime rancher shortcut? Now I've made 2 servers since I've gotten into linux which isnt very long ago. Mumble and Don't Starve Together and I can't figure this "fix" out lol. Can someone clear up that tutorial up for me? Thanks for pointing me to the guide just can't wrap my head around it.
mybestskills
Plort
 
Posts: 5
Joined: Sun Feb 07, 2016 5:22 am
Location: Canaan Indiana

Re: wont launch in Lubuntu

Postby ADragonInAPieCostume » Tue Feb 09, 2016 7:38 pm

mybestskills wrote:well me and my wife tried this. Maybe its my lack of understanding or lack of description. Is it basically telling me to copy a file into the command launch area? Like it wont let me paste the file itself... so I opened the perf file and copied the entire script which wasn't much. Where I get lost is where do I paste the perf file at? How would it look towards the end of the process instead of guessing where the pieces fit in the puzzle. What do I do with the regular slime rancher shortcut? Now I've made 2 servers since I've gotten into linux which isnt very long ago. Mumble and Don't Starve Together and I can't figure this "fix" out lol. Can someone clear up that tutorial up for me? Thanks for pointing me to the guide just can't wrap my head around it.

here is the issue (most likely). the file "perfs" at home/.config/unity3d/Monomi Park/Slime Rancher
all that tutorial is doing is creating a luncher that deletes it, you could also manually delete the file, if you want i could guide you through pm on how to do it.
i accept hugs as a thank you, im here to try and help
User avatar
ADragonInAPieCostume
Rancher
 
Posts: 37
Joined: Tue Jan 26, 2016 5:34 pm
Location: canadia

Re: wont launch in Lubuntu

Postby mybestskills » Wed Feb 10, 2016 2:30 am

well deleting the perf file and the slimerancher.prf seemed to get it unglued and it ran. But changing graphics quality higher than default makes a black screen. Well I guess I'll deal with it until the next fix! :D Thank you. I haven't "Played" yet. But thank you. Yea I did see the remove command in the guide but... throwing the pieces together was eh. A screen shot of what I'm supposed to look at would of have been great. But none the less everyone helped out. :) Thanks everyone.
mybestskills
Plort
 
Posts: 5
Joined: Sun Feb 07, 2016 5:22 am
Location: Canaan Indiana

Re: wont launch in Lubuntu

Postby Heather » Wed Feb 10, 2016 10:22 am

Thanks for the update, please keep us posted how things work out after you play ... and don't be a stranger :)

And a special thank you to ADragonInAPieCostume for taking the time to be so helpful :)
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: wont launch in Lubuntu

Postby ADragonInAPieCostume » Wed Feb 10, 2016 1:06 pm

mybestskills wrote:well deleting the perf file and the slimerancher.prf seemed to get it unglued and it ran. But changing graphics quality higher than default makes a black screen. Well I guess I'll deal with it until the next fix! :D Thank you. I haven't "Played" yet. But thank you. Yea I did see the remove command in the guide but... throwing the pieces together was eh. A screen shot of what I'm supposed to look at would of have been great. But none the less everyone helped out. :) Thanks everyone.

im working on simplifing the tutorial, and changing graphics through the oresets is kinda broken, id suggest you change everything manually, have fun
Heather wrote:Thanks for the update, please keep us posted how things work out after you play ... and don't be a stranger :)

And a special thank you to ADragonInAPieCostume for taking the time to be so helpful :)

thats what im here for :P

UPDATE: just posted the new tutorial, link: http://forums.monomipark.com/viewtopic.php?f=5&t=1522
i accept hugs as a thank you, im here to try and help
User avatar
ADragonInAPieCostume
Rancher
 
Posts: 37
Joined: Tue Jan 26, 2016 5:34 pm
Location: canadia

Re: wont launch in Lubuntu

Postby mybestskills » Fri Feb 12, 2016 8:05 am

It worked. I played for a few hours. But I did not adjust graphics settings. Ran rock solid until I was done. My wife likes the game. I bought it too just because.. somehow in the future hopefully there can be a co op function once there is enough depth in the game. Thank you. :)
mybestskills
Plort
 
Posts: 5
Joined: Sun Feb 07, 2016 5:22 am
Location: Canaan Indiana

Re: wont launch in Lubuntu

Postby Heather » Fri Feb 12, 2016 9:41 am

That's great news!
Thanks for the update :)
User avatar
Heather
Admin
 
Posts: 872
Joined: Wed Jan 13, 2016 5:48 pm

Re: wont launch in Lubuntu

Postby ADragonInAPieCostume » Fri Feb 12, 2016 6:30 pm

I'm glad it worked, and sadly there are no plans for multiplayer as of right now :/ but who knows.. maybe some day
i accept hugs as a thank you, im here to try and help
User avatar
ADragonInAPieCostume
Rancher
 
Posts: 37
Joined: Tue Jan 26, 2016 5:34 pm
Location: canadia


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests